#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<file>(?<subject>\d{4})_(?<COND>[A-Z]{2})_(?<EOEC>EO|EC)_?(?<inx>\d)?)(?<ext>\.\w{3,4})"
Local $sString = "0001_BL_EC.mat " & @CRLF & _
"1_BL_EC.mat " & @CRLF & _
"" & @CRLF & _
"1231_NF_EO.mat " & @CRLF & _
"" & @CRLF & _
"1231_NF_EO_1.mat" & @CRLF & _
"" & @CRLF & _
"S0001_NF_EO_Matrix"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")