import Foundation
let pattern = #"\"*\[*\]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"[""GROCERY""]"
"[""CHILD_NUTRITION_FOOD_PROGRAMS"",""GROCERY""]"
"[""FOOD_SERVICE""]"
"[""FOOD_SERVICE"",""GROCERY""]"
"[""CHILD_NUTRITION_FOOD_PROGRAMS""]"
"[""CHILD_NUTRITION_FOOD_PROGRAMS"",""FOOD_SERVICE""]"
"[""CHILD_NUTRITION_FOOD_PROGRAMS"",""FOOD_SERVICE"",""GROCERY""]"
"[""VENDING"",""ONLINE"",""MASS_MERCHANDISING"",""FOOD_SERVICE"",""MILITARY"",""CONVENIENCE"",""GROCERY"",""DRUG""]"
"[""ONLINE"",""CHILD_NUTRITION_FOOD_PROGRAMS"",""FOOD_SERVICE"",""GROCERY""]"
"[""ONLINE"",""FOOD_SERVICE""]"
"[""ONLINE"",""CONVENIENCE""]"
"[""ONLINE"",""GROCERY"",""DRUG""]"
"[""ONLINE"",""GROCERY""]"
"[""ONLINE"",""FOOD_SERVICE"",""GROCERY""]"
"[""ONLINE"",""FOOD_SERVICE"",""CONVENIENCE""]"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)