using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""*\[*\]*";
string substitution = @"";
string input = @"""[""GROCERY""]""
""[""CHILD_NUTRITION_FOOD_PROGRAMS"",""GROCERY""]""
""[""FOOD_SERVICE""]""
""[""FOOD_SERVICE"",""GROCERY""]""
""[""CHILD_NUTRITION_FOOD_PROGRAMS""]""
""[""CHILD_NUTRITION_FOOD_PROGRAMS"",""FOOD_SERVICE""]""
""[""CHILD_NUTRITION_FOOD_PROGRAMS"",""FOOD_SERVICE"",""GROCERY""]""
""[""VENDING"",""ONLINE"",""MASS_MERCHANDISING"",""FOOD_SERVICE"",""MILITARY"",""CONVENIENCE"",""GROCERY"",""DRUG""]""
""[""ONLINE"",""CHILD_NUTRITION_FOOD_PROGRAMS"",""FOOD_SERVICE"",""GROCERY""]""
""[""ONLINE"",""FOOD_SERVICE""]""
""[""ONLINE"",""CONVENIENCE""]""
""[""ONLINE"",""GROCERY"",""DRUG""]""
""[""ONLINE"",""GROCERY""]""
""[""ONLINE"",""FOOD_SERVICE"",""GROCERY""]""
""[""ONLINE"",""FOOD_SERVICE"",""CONVENIENCE""]""
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}