const regex = new RegExp('^(?P<begin>\\d{2}\\/\\d{2}\\/\\d{4})\\s\\-\\s(?P<end>\\d{2}\\/\\d{2}\\/\\d{4})$', 'gm')
const str = `08/17/2020 - 08/23/2020`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}