import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<begin>\\d{2}\\/\\d{2}\\/\\d{4})\\s\\-\\s(?P<end>\\d{2}\\/\\d{2}\\/\\d{4})$";
final String string = "08/17/2020 - 08/23/2020";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}