using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<begin>\d{2}\/\d{2}\/\d{4})\s\-\s(?P<end>\d{2}\/\d{2}\/\d{4})$";
string input = @"08/17/2020 - 08/23/2020";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}