// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)((low-|\d-|<-|<|->|>)\d*$)|other|low-high|(^\dhigh$)|^\d*$").unwrap();
let string = "low-18
-20
19
20<-40
41-70
71-high
71-higher
low-71-high
lower-71
high-low
low-high
other
71-turn";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}