using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((low-|\d-|<-|<|->|>)\d*$)|other|low-high|(^\dhigh$)|^\d*$";
string input = @"low-18
-20
19
20<-40
41-70
71-high
71-higher
low-71-high
lower-71
high-low
low-high
other
71-turn";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}