re = /((low-|\d-|<-|<|->|>)\d*$)|other|low-high|(^\dhigh$)|^\d*$/mi
str = 'low-18
-20
19
20<-40
41-70
71-high
71-higher
low-71-high
lower-71
high-low
low-high
other
71-turn'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end