// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(\bcout)(s\b|\b)").unwrap();
let string = "Test de remplacement de cout.
Egalement gout, tache, cout, maitrise. Par contre on ne remplace pas coût ni tâche.
Test également au pluriel de couts et de goût. ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}