re = /(\bcout)(s\b|\b)/mi
str = 'Test de remplacement de cout.
Egalement gout, tache, cout, maitrise. Par contre on ne remplace pas coût ni tâche.
Test également au pluriel de couts et de goût. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end