#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(\bcout)(s\b|\b)"
Local $sString = "Test de remplacement de cout." & @CRLF & _
"Egalement gout, tache, cout, maitrise. Par contre on ne remplace pas coût ni tâche." & @CRLF & _
"Test également au pluriel de couts et de goût. "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")