$re = '~[cfM]an~m';
$str = 'MATCH:
can
fan
Man
DON\'T MATCH:
ran
tan
lan';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);