#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[cfM]an"
Local $sString = "MATCH:" & @CRLF & _
"" & @CRLF & _
"can" & @CRLF & _
"fan" & @CRLF & _
"Man" & @CRLF & _
"" & @CRLF & _
"DON'T MATCH:" & @CRLF & _
"" & @CRLF & _
"ran" & @CRLF & _
"tan" & @CRLF & _
"lan"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")