package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[cfM]an`)
var str = `MATCH:
can
fan
Man
DON'T MATCH:
ran
tan
lan`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}