re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[-\@\#\$\.\%\&\*\!\+\_\=\?\'\{\}\(\)\/])([a-zA-Z0-9-\@\#\$\.\%\&\*\!\+\_\=\?\'\{\}\(\)\/]{8,16})$/m
str = 'Te23!\'/()_a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end