using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[-\@\#\$\.\%\&\*\!\+\_\=\?\'\{\}\(\)\/])([a-zA-Z0-9-\@\#\$\.\%\&\*\!\+\_\=\?\'\{\}\(\)\/]{8,16})$";
string input = @"Te23!'/()_a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}