$re = '/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[-\@\#\$\.\%\&\*\!\+\_\=\?\'\{\}\(\)\/])([a-zA-Z0-9-\@\#\$\.\%\&\*\!\+\_\=\?\'\{\}\(\)\/]{8,16})$/m';
$str = 'Te23!\'/()_a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);