use strict;
my $str = ' ADM_RPT_COL
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_STARS_DAT
ADM_RPT_HDR
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_STARS_DAT
ADM_USER_PREF
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_INFMT_DAT ';
my $regex = qr/\s+ \w+\s+={37}\s+Table tablespaces do not match\. Destination : SUM_DEMO_(\w+) Source : SFDEV_(\1)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}