const regex = /\s+ \w+\s+={37}\s+Table tablespaces do not match\. Destination : SUM_DEMO_(\w+) Source : SFDEV_(\1)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+ \\w+\\s+={37}\\s+Table tablespaces do not match\\. Destination : SUM_DEMO_(\\w+) Source : SFDEV_(\\1)', 'g')
const str = ` ADM_RPT_COL
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_STARS_DAT
ADM_RPT_HDR
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_STARS_DAT
ADM_USER_PREF
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_INFMT_DAT `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}