import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+ \\w+\\s+={37}\\s+Table tablespaces do not match\\. Destination : SUM_DEMO_(\\w+) Source : SFDEV_(\\1)";
final String string = " ADM_RPT_COL\n"
+ " =====================================\n"
+ " Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_STARS_DAT \n\n"
+ " ADM_RPT_HDR\n"
+ " =====================================\n"
+ " Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_STARS_DAT \n\n"
+ " ADM_USER_PREF\n"
+ " =====================================\n"
+ " Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_INFMT_DAT ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}