// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<name>\w+)\((?<content>(.*|(\R)).*)\)").unwrap();
let string = "sin0+sin90+sin(90+sin(sin(sin())))+sin(0)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}