using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<name>\w+)\((?<content>(.*|(\R)).*)\)";
string input = @"sin0+sin90+sin(90+sin(sin(sin())))+sin(0)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}