package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<name>\w+)\((?<content>(.*|(\R)).*)\)`)
var str = `sin0+sin90+sin(90+sin(sin(sin())))+sin(0)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}