// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"the").unwrap();
let string = "Text starts with (Regex Expression /)
This test is to help with the Regex when the symbol is / and looks for any text where the text is contained
Change the box above to have the word the and it will match all the thes in the text, this is case sensitive.
-------------
Text starts with (Regex Expression ^)
This test is to help with the Regex when the symbol is ^ and looks for text which starts with ^
Change the box above to have the word ^Text and it will match the first example.
-------------
Text ends with (Regex Expression $)
This test is to help with the Regex when the symbol is $ and looks for text which ends with xxxxx$
Change the box above to have the word example$ and make sure that you are looking at the multi-line add this in the text field at the top near the g (will not be relevant for URL) and it will match the last example
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}