# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"the"
test_str = ("Text starts with (Regex Expression /)\n\n"
"This test is to help with the Regex when the symbol is / and looks for any text where the text is contained\n\n"
"Change the box above to have the word the and it will match all the thes in the text, this is case sensitive.\n"
"-------------\n"
"Text starts with (Regex Expression ^)\n\n"
"This test is to help with the Regex when the symbol is ^ and looks for text which starts with ^\n\n"
"Change the box above to have the word ^Text and it will match the first example.\n"
"-------------\n"
"Text ends with (Regex Expression $)\n\n"
"This test is to help with the Regex when the symbol is $ and looks for text which ends with xxxxx$\n\n"
"Change the box above to have the word example$ and make sure that you are looking at the multi-line add this in the text field at the top near the g (will not be relevant for URL) and it will match the last example\n\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.