import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "the";
final String string = "Text starts with (Regex Expression /)\n\n"
+ "This test is to help with the Regex when the symbol is / and looks for any text where the text is contained\n\n"
+ "Change the box above to have the word the and it will match all the thes in the text, this is case sensitive.\n"
+ "-------------\n"
+ "Text starts with (Regex Expression ^)\n\n"
+ "This test is to help with the Regex when the symbol is ^ and looks for text which starts with ^\n\n"
+ "Change the box above to have the word ^Text and it will match the first example.\n"
+ "-------------\n"
+ "Text ends with (Regex Expression $)\n\n"
+ "This test is to help with the Regex when the symbol is $ and looks for text which ends with xxxxx$\n\n"
+ "Change the box above to have the word example$ and make sure that you are looking at the multi-line add this in the text field at the top near the g (will not be relevant for URL) and it will match the last example\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}