$re = '/(?:\s*(\w+)\s*=\s*(?:\'((?:[^\'\\\\]|\\\\")*)\'|"((?:[^"\\\\]|\\\\")*)"?|(\w+)))/';
$str = '{keyword name1=val1 name2=\'val2\' name3="val3" name4="Isn\'t this OK?" name5=okay name6=\'Isn\\\'t\' name7="A \\"quote\\""}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);