use strict;
my $str = '{keyword name1=val1 name2=\'val2\' name3="val3" name4="Isn\'t this OK?" name5=okay name6=\'Isn\\\'t\' name7="A \\"quote\\""}';
my $regex = qr/(?:\s*(\w+)\s*=\s*(?:'((?:[^'\\]|\\")*)'|"((?:[^"\\]|\\")*)"?|(\w+)))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}