package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s*(\w+)\s*=\s*(?:'((?:[^'\\]|\\")*)'|"((?:[^"\\]|\\")*)"?|(\w+)))`)
var str = `{keyword name1=val1 name2='val2' name3="val3" name4="Isn't this OK?" name5=okay name6='Isn\'t' name7="A \"quote\""}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}