re = /^([abcdefghijklmnopqrstuvwxyz01234567890-]+\.)+[abcdefghijklmnopqrstuvwxyz01234567890\-]+$/m
str = 'somedomain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end