package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([abcdefghijklmnopqrstuvwxyz01234567890-]+\.)+[abcdefghijklmnopqrstuvwxyz01234567890\-]+$`)
var str = `somedomain.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}