$re = '/^([abcdefghijklmnopqrstuvwxyz01234567890-]+\.)+[abcdefghijklmnopqrstuvwxyz01234567890\-]+$/m';
$str = 'somedomain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);