re = /(["'])((?:\\\1|(?!\1).)+)\1/
str = '{if Server:GetPhpSelf == "/ind\'ex.php"}
foo \'hhhh"hhh""hhh\' plonk
foo "meep\\"meep" plonk
foo \'meep\\\'meep\' plonk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end