import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\"'])((?:\\\\\\1|(?!\\1).)+)\\1";
final String string = "{if Server:GetPhpSelf == \"/ind'ex.php\"}\n"
+ "foo 'hhhh\"hhh\"\"hhh' plonk\n"
+ "foo \"meep\\\"meep\" plonk\n"
+ "foo 'meep\\'meep' plonk";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}