using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([""'])((?:\\\1|(?!\1).)+)\1";
string input = @"{if Server:GetPhpSelf == ""/ind'ex.php""}
foo 'hhhh""hhh""hhh' plonk
foo ""meep\""meep"" plonk
foo 'meep\'meep' plonk";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}