$re = '/\<style\>(.*)\<\/style\>/s';
$str = 'zaeazeaze
<style>z
a{
a
}
qsd</style>
dazea';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);