package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\<style\>(.*)\<\/style\>`)
var str = `zaeazeaze
<style>z
a{
a
}
qsd</style>
dazea`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}