#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\<style\>(.*)\<\/style\>"
Local $sString = "zaeazeaze" & @CRLF & _
"<style>z" & @CRLF & _
"a{" & @CRLF & _
"a" & @CRLF & _
"}" & @CRLF & _
"qsd</style>" & @CRLF & _
"dazea"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")