const regex = /[^0-9A-Z0-9\à\è\é\ì\ò\ù\€_\,\;\:\!\.\-\+\*\/\(\)\[\]\?=\@\%\&#\s]/ium;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^0-9A-Z0-9\\à\\è\\é\\ì\\ò\\ù\\€_\\,\\;\\:\\!\\.\\-\\+\\*\\\/\\(\\)\\[\\]\\?=\\@\\%\\&#\\s]', 'ium')
const str = `punteggiatura !.,?:;@+-%=
#
<>
includere sconto 50%
perché però qualità più mercoledì
10 €
come ordine dell'altra volta
"citazione"
`;
const subst = `!!!`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);