import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^0-9A-Z0-9\\à\\è\\é\\ì\\ò\\ù\\€_\\,\\;\\:\\!\\.\\-\\+\\*\\/\\(\\)\\[\\]\\?=\\@\\%\\&#\\s]";
final String string = "punteggiatura !.,?:;@+-%=\n"
+ "#\n"
+ "<> \n"
+ "includere sconto 50%\n"
+ "perché però qualità più mercoledì\n"
+ "10 €\n"
+ "come ordine dell'altra volta\n"
+ "\"citazione\"\n";
final String subst = "!!!";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}