$re = '/^(?=.*\baxis)(?=.*\bregular)(?=.*\bbluechip)/mi';
$str = 'Axis bluechip regular growth
Mirae Bluechip direct
ABSL 96 direct
Axis bluechip direct
Axis all seasons direct
Axis some seasons ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);