#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=.*\baxis)(?=.*\bregular)(?=.*\bbluechip)"
Local $sString = "Axis bluechip regular growth" & @CRLF & _
"Mirae Bluechip direct" & @CRLF & _
"ABSL 96 direct" & @CRLF & _
"Axis bluechip direct" & @CRLF & _
"Axis all seasons direct" & @CRLF & _
"Axis some seasons "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")