const regex = /^(?=.*\baxis)(?=.*\bregular)(?=.*\bbluechip)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\baxis)(?=.*\\bregular)(?=.*\\bbluechip)', 'gmi')
const str = `Axis bluechip regular growth
Mirae Bluechip direct
ABSL 96 direct
Axis bluechip direct
Axis all seasons direct
Axis some seasons `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}