re = /([_a-z]\w*)=\s*([^;|^&]*)/
str = 'key=something; value=something& ahmed=30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end