$re = '/([_a-z]\w*)=\s*([^;|^&]*)/';
$str = 'key=something; value=something& ahmed=30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);