package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([_a-z]\w*)=\s*([^;|^&]*)`)
var str = `key=something; value=something& ahmed=30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}