use strict;
my $str = '
sdkjhskadjhfkhsadf
adfsafdsafsad
Umidade.............=18,9 %
dsafsdafsda
UMIDADE: 7.0%
sfadfsad
Umidade:10.4%
Umidade :10.4%
---------------------';
my $regex = qr/(?P<STRING>.*umidade.*?[=|:|])(?P<VALOR>\d.*\d)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}