package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?P<STRING>.*umidade.*?[=|:|])(?P<VALOR>\d.*\d)`)
var str = `
sdkjhskadjhfkhsadf
adfsafdsafsad
Umidade.............=18,9 %
dsafsdafsda
UMIDADE: 7.0%
sfadfsad
Umidade:10.4%
Umidade :10.4%
---------------------`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}