const regex = /(?P<STRING>.*umidade.*?[=|:|])(?P<VALOR>\d.*\d)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?P<STRING>.*umidade.*?[=|:|])(?P<VALOR>\\d.*\\d)', 'gmi')
const str = `
sdkjhskadjhfkhsadf
adfsafdsafsad
Umidade.............=18,9 %
dsafsdafsda
UMIDADE: 7.0%
sfadfsad
Umidade:10.4%
Umidade :10.4%
---------------------`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}